rbenvを最新にして新しいバージョンのRubyをインストールできるようにする

Tags: [ Ruby ] Published: 2017/03/30

あらすじ

  • git cloneでインストールしたrbenvを最新にして新しいRubyをインストールする

ちょくちょく忘れるので

手順

Basic GitHub Checkout に沿ってインストールすると、カレントディレクトリ直下に ~/.rbenv~/.rbenv/plugins/ruby-build があるはず。ここを最新にする。

$ cd ~/.rbenv
$ git pull
$ cd ~/.rbenv/plugins/ruby-build
$ git pull

$ rbenv install -l を実行してインストールできるRubyのバージョンを確認みる。

好きなバージョンをインストールする。

blog comments powered by Disqus

Author: kk_Ataka / Powered by Jekyll on GitHub Pages